GHSA-j4pr-3wm6-xx2r

URI Credential Leakage Bypass over CVE-2025-27221

At a glance

Published
Updated
CVE
CVE-2025-61594
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Description

### Impact In affected URI version, a bypass exists for the fix to CVE-2025-27221 that can expose user credentials. When using the `+` operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. The vulnerability affects the `uri` gem bundled with the following Ruby series: * 0.12.4 and earlier (bundled in Ruby 3.2 series) * 0.13.2 and earlier (bundled in Ruby 3.3 series) * 1.0.3 and earlier (bundled in Ruby 3.4 series) ### Patches Upgrade to 0.12.5, 0.13.3 or 1.0.4 ### References * https://www.ruby-lang.org/en/news/2025/02/26/security-advisories/ * https://hackerone.com/reports/2957667

Affected packages

PackageVersions
RubyGems · uriintroduced 0, fixed 0.12.5
RubyGems · uriintroduced 0.13.0, fixed 0.13.3
RubyGems · uriintroduced 1.0.0, fixed 1.0.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database