GHSA-j482-47xf-p25c
Apache Airflow Potential Cross-site Scripting Vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2024-39863
- Aliases
- BIT-airflow-2024-39863, PYSEC-2024-189
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Description
Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.9.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-39863 ADVISORY
- https://github.com/apache/airflow/pull/40475 WEB
- https://github.com/apache/airflow/commit/f18f48492dc69f392e45567580b6ddb0c070ea58 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2024-189.yaml WEB
- https://lists.apache.org/thread/gxkvs279f1mbvckv5q65worr6how20o3 WEB
- http://www.openwall.com/lists/oss-security/2024/07/16/6 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |