GHSA-j44m-qm6p-hp7m

Arbitrary File Overwrite in tar

At a glance

Published
Updated
CVE
CVE-2018-20834
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

Versions of `tar` prior to 4.4.2 for 4.x and 2.2.2 for 2.x are vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink will overwrite the system's file with the contents of the extracted file. ## Recommendation For tar 4.x, upgrade to version 4.4.2 or later. For tar 2.x, upgrade to version 2.2.2 or later.

Affected packages

PackageVersions
npm · tarintroduced 3.0.0, fixed 4.4.2
npm · tarintroduced 0, fixed 2.2.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database