GHSA-j3w8-2p2h-mrr9
Apache Airflow vulnerable to privilege escalation
At a glance
- Published
- Updated
- CVE
- CVE-2023-42792
- Aliases
- BIT-airflow-2023-42792, PYSEC-2023-203
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Description
Apache Airflow, in versions prior to 2.7.2, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. Users of Apache Airflow are strongly advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.7.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-42792 ADVISORY
- https://github.com/apache/airflow/pull/34366 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-203.yaml WEB
- https://lists.apache.org/thread/1spbo9nkn49fc2hnxqm9tf6mgqwp9tjq WEB
- http://www.openwall.com/lists/oss-security/2023/12/21/1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |