GHSA-j288-q9x7-2f5v

Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs

En bref

Publiée
Mise à jour
CVE
CVE-2025-48924
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Description

Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.commons:commons-lang3introduced 3.0, fixed 3.18.0
Maven · commons-lang:commons-langintroduced 2.0, last affected 2.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database