GHSA-hwrj-9rr4-24xh
Apache Thrift Python bindings have a Improper Validation of Certificate with Host Mismatch vulnerabilit
At a glance
- Published
- Updated
- CVE
- CVE-2026-66053
- Aliases
- BIT-thrift-2026-66053, PYSEC-2026-3927
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603
Affected packages
| Package | Versions |
|---|---|
| PyPI · thrift | introduced 0, fixed 0.24.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-66053 ADVISORY
- https://github.com/apache/thrift PACKAGE
- https://lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9 WEB
- https://lists.apache.org/thread/w4k5dnv1x58knwlhpo9x0or5xh220y65 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |