GHSA-hwj9-h5mp-3pm3

Regular Expression Denial of Service in postcss

En bref

Publiée
Mise à jour
CVE
CVE-2021-23368
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Description

The npm package `postcss` from 7.0.0 and before versions 7.0.36 and 8.2.10 is vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Paquets affectés

PaquetVersions
npm · postcssintroduced 7.0.0, fixed 7.0.36
npm · postcssintroduced 8.0.0, fixed 8.2.10

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database