GHSA-hw8r-x6gr-5gjp

JSONPath Plus allows Remote Code Execution

En bref

Publiée
Mise à jour
CVE
CVE-2025-1302
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Description

Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode. **Note:** This is caused by an incomplete fix for CVE-2024-21534.

Paquets affectés

PaquetVersions
npm · jsonpath-plusintroduced 0, fixed 10.3.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database