GHSA-hvf5-4jr9-fghh

Magento incorrect permissions vulnerability in the Integrations component

En bref

Publiée
Mise à jour
CVE
CVE-2020-24402
Alias
BIT-magento-2020-24402
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N

Description

Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions vulnerability in the Integrations component. This vulnerability could be abused by authenticated users with permissions to the Resource Access API to delete customer details via the REST API without authorization.

Paquets affectés

PaquetVersions
Packagist · magento/community-editionintroduced 0, fixed 2.3.6
Packagist · magento/community-editionintroduced 2.4.0, fixed 2.4.1
Packagist · magento/project-community-editionintroduced 0, last affected 2.0.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database