GHSA-hv9c-qwqg-qj3v

Electron webPreferences vulnerability can be used to perform remote code execution

At a glance

Published
Updated
CVE
CVE-2018-15685
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or "sandbox: true" options, is affected by a webPreferences vulnerability that can be leveraged to perform remote code execution. More information to determine if you are impacted can be found on the [electron blog](https://electronjs.org/blog/web-preferences-fix). ## Recommendation Upgrade Electron to >=3.0.0-beta.7, >=2.0.8, >=1.8.8, or >=1.7.16.

Affected packages

PackageVersions
npm · electronintroduced 1.7.0, fixed 1.7.16
npm · electronintroduced 1.8.0, fixed 1.8.8
npm · electronintroduced 2.0.0, fixed 2.0.8
npm · electronintroduced 3.0.0-beta.1, fixed 3.0.0-beta.7

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database