GHSA-hv45-5j9h-7fhg
Cross-site Scripting in Jenkins
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2018-1000407
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
A cross-site scripting vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and earlier in core/src/main/java/hudson/model/Api.java that allows attackers to specify URLs to Jenkins that result in rendering arbitrary attacker-controlled HTML by Jenkins.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.138.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.140, fixed 2.146 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000407 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/df87e12ddcfeafdba6e0de0e07b3e21f8473ece6 WEB
- https://jenkins.io/security/advisory/2018-10-10/#SECURITY-1129 WEB
- http://www.securityfocus.com/bid/106532 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |