GHSA-hrg3-4q56-p2q5

Magento 2 Community Edition DoS vulnerability

At a glance

Published
Updated
CVE
CVE-2019-7928
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

A denial-of-service (DoS) vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. By abusing insufficient brute-forcing defenses in the token exchange protocol, an unauthenticated attacker could disrupt transactions between the Magento merchant and PayPal.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.1.0, fixed 2.1.18
Packagist · magento/community-editionintroduced 2.2.0, fixed 2.2.9
Packagist · magento/community-editionintroduced 2.3.0, fixed 2.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database