GHSA-hqf9-rc9j-5fmj
Array data injection vulnerability in activerecord
At a glance
- Published
- Updated
- CVE
- CVE-2014-0080
Description
SQL injection vulnerability in `activerecord/lib/active_record/connection_adapters/postgresql/cast.rb` in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving `\` (backslash) characters that are not properly handled in operations on array columns.
Affected packages
| Package | Versions |
|---|---|
| RubyGems · activerecord | introduced 4.0.0, fixed 4.0.3 |
| RubyGems · activerecord | introduced 4.1.0.beta1, fixed 4.1.0.beta2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-0080 ADVISORY
- https://github.com/advisories/GHSA-hqf9-rc9j-5fmj ADVISORY
- https://github.com/rails/rails/tree/main/activerecord PACKAGE
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2014-0080.yml WEB
- https://web.archive.org/web/20210301004521/https://groups.google.com/forum/message/raw?msg=rubyonrails-security/Wu96YkTUR6s/pPLBMZrlwvYJ WEB
- http://openwall.com/lists/oss-security/2014/02/18/9 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |