GHSA-hpcf-8vf9-q4gj

jQuery-UI vulnerable to Cross-site Scripting in dialog closeText

At a glance

Published
Updated
CVE
CVE-2016-7103
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Affected versions of `jquery-ui` are vulnerable to a cross-site scripting vulnerability when arbitrary user input is supplied as the value of the `closeText` parameter in the `dialog` function. jQuery-UI is a library for manipulating UI elements via jQuery. Version 1.11.4 has a cross site scripting (XSS) vulnerability in the `closeText` parameter of the `dialog` function. If your application passes user input to this parameter, it may be vulnerable to XSS via this attack vector. ## Recommendation Upgrade to jQuery-UI 1.12.0 or later.

Affected packages

PackageVersions
npm · jquery-uiintroduced 0, fixed 1.12.0
RubyGems · jquery-ui-railsintroduced 0, fixed 6.0.0
Maven · org.webjars.npm:jquery-uiintroduced 0, fixed 1.12.0
NuGet · jQuery.UI.Combinedintroduced 0, fixed 1.12.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database