GHSA-hm9r-7f84-25c9

Apache Airflow allows authenticated and DAG-view authorized users to modify some DAG run detail values when submitting notes

At a glance

Published
Updated
CVE
CVE-2023-47037
Aliases
BIT-airflow-2023-47037, PYSEC-2023-232
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Description

Apache Airflow, versions before 2.7.3, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc.  Users should upgrade to version 2.7.3 or later which has removed the vulnerability.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.7.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database