GHSA-hhm6-jjf4-6pm3

Apache Airflow MySQL Provider is Vulnerable to SQL Injection

At a glance

Published
Updated
CVE
CVE-2025-27018
Aliases
PYSEC-2026-1151
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider. When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.

Affected packages

PackageVersions
PyPI · apache-airflow-providers-mysqlintroduced 0, fixed 6.2.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database