GHSA-hhhw-99gj-p3c3
snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write
At a glance
- Published
- Updated
- CVE
- CVE-2022-38750
- CVSS_V3
- CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Description
Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.yaml:snakeyaml | introduced 0, fixed 1.31 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38750 ADVISORY
- https://bitbucket.org/snakeyaml/snakeyaml PACKAGE
- https://bitbucket.org/snakeyaml/snakeyaml/issues/526/stackoverflow-oss-fuzz-47027 WEB
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47027 WEB
- https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html WEB
- https://security.gentoo.org/glsa/202305-28 WEB
- https://security.netapp.com/advisory/ntap-20240315-0010 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |