GHSA-hh8r-75r6-qrg9

Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters

En bref

Publiée
Mise à jour
CVE
CVE-2026-49042
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.camel:camel-langchain4j-toolsintroduced 4.8.0, fixed 4.18.3
Maven · org.apache.camel:camel-langchain4j-toolsintroduced 4.19.0, fixed 4.21.0
Maven · org.apache.camel:camel-langchain4j-agentintroduced 4.8.0, fixed 4.18.3
Maven · org.apache.camel:camel-langchain4j-agentintroduced 4.19.0, fixed 4.21.0
Maven · org.apache.camel:camel-spring-ai-toolsintroduced 4.8.0, fixed 4.18.3
Maven · org.apache.camel:camel-spring-ai-toolsintroduced 4.19.0, fixed 4.21.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database