GHSA-hgjp-83m4-h4fj

MySQL Connector/Python connector takeover vulnerability

At a glance

Published
Updated
CVE
CVE-2024-21272
Aliases
PYSEC-2026-1685
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/Python). Supported versions that are affected are 9.0.0 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H).

Affected packages

PackageVersions
PyPI · mysql-connector-pythonintroduced 0, fixed 9.1.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database