GHSA-hffm-xvc3-vprc

simple-git is vulnerable to Remote Code Execution

En bref

Publiée
Mise à jour
CVE
CVE-2026-6951
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Description

Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.

Paquets affectés

PaquetVersions
npm · simple-gitintroduced 0, fixed 3.36.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database