GHSA-h9rv-jmmf-4pgx
Cross-Site Scripting in serialize-javascript
At a glance
- Published
- Updated
- CVE
- CVE-2019-16769
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L
Description
Versions of `serialize-javascript` prior to 2.1.1 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize serialized regular expressions. This vulnerability does not affect Node.js applications. ## Recommendation Upgrade to version 2.1.1 or later.
Affected packages
| Package | Versions |
|---|---|
| npm · serialize-javascript | introduced 0, fixed 2.1.1 |
References
- https://github.com/yahoo/serialize-javascript/security/advisories/GHSA-h9rv-jmmf-4pgx WEB
- https://nvd.nist.gov/vuln/detail/CVE-2019-16769 ADVISORY
- https://github.com/advisories/GHSA-h9rv-jmmf-4pgx ADVISORY
- https://www.npmjs.com/advisories/1426 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |