GHSA-h9rh-5ffh-h669
OSGeo GDAL vulnerable to heap-based buffer overflow
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-8087
- Alias
- BIT-gdal-2026-8087, PYSEC-2026-2155
- CVSS_V3
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS_V4
- CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
Description
A security flaw has been discovered in OSGeo gdal up to 3.13.0dev-4. Impacted is the function GDnentries of the file frmts/hdf4/hdf-eos/GDapi.c. Performing a manipulation of the argument DataFieldName results in heap-based buffer overflow. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. Upgrading to version 3.13.0RC1 is recommended to address this issue. The patch is named 184f77dbcc74118c062c05e464c88161d3c37b9b. You should upgrade the affected component.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · gdal | introduced 0, fixed 3.13.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2026-8087 ADVISORY
- https://github.com/OSGeo/gdal/issues/14363 WEB
- https://github.com/OSGeo/gdal/commit/184f77dbcc74118c062c05e464c88161d3c37b9b WEB
- https://github.com/OSGeo/gdal PACKAGE
- https://github.com/OSGeo/gdal/releases/tag/v3.13.0RC1 WEB
- https://github.com/biniamf/pocs/tree/main/gdal-gdinqfields_bof WEB
- https://vuldb.com/submit/808039 WEB
- https://vuldb.com/vuln/361840 WEB
- https://vuldb.com/vuln/361840/cti WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |