GHSA-h8wv-9h96-m4hr

Onnx Out-of-bounds Read vulnerability

At a glance

Published
Updated
CVE
CVE-2024-27319
Aliases
PYSEC-2024-223
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L

Description

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Affected packages

PackageVersions
PyPI · onnxintroduced 0, fixed 1.16.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database