GHSA-h8q5-g2cj-qr5h
Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack
At a glance
- Published
- Updated
- CVE
- CVE-2018-11796
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.tika:tika-core | introduced 0.1, fixed 1.19.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-11796 ADVISORY
- https://access.redhat.com/errata/RHSA-2019:3892 WEB
- https://github.com/advisories/GHSA-h8q5-g2cj-qr5h ADVISORY
- https://github.com/apache/tika PACKAGE
- https://lists.apache.org/thread.html/88de8350cda9b184888ec294c813c5bd8a2081de8fd3666f8904bc05@%3Cdev.tika.apache.org%3E WEB
- https://security.netapp.com/advisory/ntap-20190903-0002 WEB
- http://www.securityfocus.com/bid/105585 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |