GHSA-h6g5-wqqr-3mw3
Sensitive Information in Error Messages in Apache Airflow
At a glance
- Published
- Updated
- CVE
- CVE-2023-25695
- Aliases
- BIT-airflow-2023-25695, PYSEC-2023-2
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Description
Generation of Error Message Containing Sensitive Information vulnerability in Apache Software Foundation Apache Airflow.This issue affects Apache Airflow: before 2.5.2. The traceback contains information that might be useful for a potential attacker to better target their attack (Python/Airflow version, node name). This information should not be shown if traceback is shown to unauthenticated user.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.5.2rc1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-25695 ADVISORY
- https://github.com/apache/airflow/pull/29501 WEB
- https://github.com/apache/airflow/commit/965e76d9ed00ef354a834739ac46f24068630951 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-2.yaml WEB
- https://lists.apache.org/thread/z8w6ckzs61ql365tv4d19k82o67r15p2 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |