GHSA-h63r-9xxf-f2c7

Apache Airflow Cross-site Scripting vulnerability

At a glance

Published
Updated
CVE
CVE-2022-43982
Aliases
BIT-airflow-2022-43982, PYSEC-2022-42970
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

In Apache Airflow versions prior to 2.4.2, the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.4.2rc1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database