GHSA-h4xc-577p-hgj9
Magento cross-site request forgery (CSRF) vulnerability via the GraphQL API
At a glance
- Published
- Updated
- CVE
- CVE-2021-21027
- Aliases
- BIT-magento-2021-21027
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via the GraphQL API. Successful exploitation could lead to unauthorized modification of customer metadata by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.
Affected packages
| Package | Versions |
|---|---|
| Packagist · magento/community-edition | introduced 0, fixed 2.3.6-p1 |
| Packagist · magento/community-edition | introduced 2.4.0, fixed 2.4.2 |
| Packagist · magento/project-community-edition | introduced 0, last affected 2.0.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21027 ADVISORY
- https://github.com/magento/magento2/commit/a2eb7e29ea92a8bbc86c3b6b81b59d8533088497 WEB
- https://github.com/magento/magento2/commit/a349e022c9ae070e7da262021f9ef182105aa00b WEB
- https://github.com/magento/magento2 PACKAGE
- https://helpx.adobe.com/security/products/magento/apsb21-08.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |