GHSA-h468-7pvh-8vr8

Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor

En bref

Publiée
Mise à jour
CVE
CVE-2026-29146
Alias
BIT-tomcat-2026-29146
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-tribesintroduced 9.0.13, fixed 9.0.116
Maven · org.apache.tomcat:tomcat-tribesintroduced 10.1.50, fixed 10.1.53
Maven · org.apache.tomcat:tomcat-tribesintroduced 11.0.0-M1, fixed 11.0.20
Maven · org.apache.tomcat:tomcatintroduced 9.0.13, fixed 9.0.116
Maven · org.apache.tomcat:tomcatintroduced 10.1.50, fixed 10.1.53
Maven · org.apache.tomcat:tomcatintroduced 11.0.0-M1, fixed 11.0.20
Maven · org.apache.tomcat:tomcat-tribesintroduced 8.5.38, last affected 8.5.100
Maven · org.apache.tomcat:tomcatintroduced 8.5.38, last affected 8.5.100
Maven · org.apache.tomcat:tomcat-tribesintroduced 7.0.100, last affected 7.0.109
Maven · org.apache.tomcat:tomcatintroduced 7.0.100, last affected 7.0.109

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database