GHSA-h2fw-rfh5-95r3

Apache Tomcat - CGI security constraint bypass

En bref

Publiée
Mise à jour
CVE
CVE-2025-46701
Alias
BIT-tomcat-2025-46701
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U/U:Clear

Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-catalinaintroduced 9.0.0.M1, fixed 9.0.105
Maven · org.apache.tomcat:tomcat-catalinaintroduced 10.1.0-M1, fixed 10.1.41
Maven · org.apache.tomcat:tomcat-catalinaintroduced 11.0.0-M1, fixed 11.0.7
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.0.M1, fixed 9.0.105
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.0-M1, fixed 10.1.41
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M1, fixed 11.0.7
Maven · org.apache.tomcat:tomcat-catalinaintroduced 8.5.0, last affected 8.5.100
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 8.5.0, last affected 8.5.100

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database