GHSA-gxr4-xjj5-5px2

Potential XSS vulnerability in jQuery

En bref

Publiée
Mise à jour
CVE
CVE-2020-11022
Alias
BIT-drupal-2020-11022
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N

Description

### Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. `.html()`, `.append()`, and others) may execute untrusted code. ### Patches This problem is patched in jQuery 3.5.0. ### Workarounds To workaround the issue without upgrading, adding the following to your code: ```js jQuery.htmlPrefilter = function( html ) { return html; }; ``` You need to use at least jQuery 1.12/2.2 or newer to be able to apply this workaround. ### References https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ https://jquery.com/upgrade-guide/3.5/ ### For more information If you have any questions or comments about this advisory, search for a relevant issue in [the jQuery repo](https://github.com/jquery/jquery/issues). If you don't find an answer, open a new issue.

Paquets affectés

PaquetVersions
npm · jqueryintroduced 1.12.0, fixed 3.5.0
NuGet · jqueryintroduced 1.12.0, fixed 3.5.0
RubyGems · jquery-railsintroduced 0, fixed 4.4.0
Maven · org.webjars.npm:jqueryintroduced 1.12.0, fixed 3.5.0
Packagist · maximebf/debugbarintroduced 0, fixed 1.19.0
Packagist · athlon1600/youtube-downloaderintroduced 0, fixed 4.0.1
Packagist · components/jqueryintroduced 1.12.0, fixed 3.5.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database