GHSA-gqp3-2cvr-x8m3

Apache Tomcat Improper Resource Shutdown or Release vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2025-48989
Alias
BIT-tomcat-2025-48989
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected. Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-coyoteintroduced 11.0.0-M1, fixed 11.0.10
Maven · org.apache.tomcat:tomcat-coyoteintroduced 10.1.0-M1, fixed 10.1.44
Maven · org.apache.tomcat:tomcat-coyoteintroduced 9.0.0.M1, fixed 9.0.108
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M1, fixed 11.0.10
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.0-M1, fixed 10.1.44
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.0.M1, fixed 9.0.108

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database