GHSA-gmg8-593g-7mv3
Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing
At a glance
- Published
- Updated
- CVE
- CVE-2025-31672
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Description
Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.poi:poi-ooxml | introduced 0, fixed 5.4.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-31672 ADVISORY
- https://bz.apache.org/bugzilla/show_bug.cgi?id=69620 WEB
- https://github.com/apache/poi PACKAGE
- https://lists.apache.org/thread/k14w8vcjqy4h34hh5kzldko78kpylkq5 WEB
- https://security.netapp.com/advisory/ntap-20250523-0004 WEB
- http://www.openwall.com/lists/oss-security/2025/04/08/2 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |