GHSA-gjx9-wg9x-7gvp
Flowise Vulnerable to SQL Injection via `tableName` Parameter
At a glance
- Published
- Updated
- CVE
- CVE-2025-29189
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
Description
Flowise <= 2.2.3 is vulnerable to SQL Injection. via tableName parameter at Postgres_VectorStores.
Affected packages
| Package | Versions |
|---|---|
| npm · flowise-components | introduced 0, fixed 2.2.4 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-29189 ADVISORY
- https://github.com/FlowiseAI/Flowise/pull/3818 WEB
- https://github.com/FlowiseAI/Flowise/commit/9a417bdc95f58d6dd92cbf60dad42414aba34754 WEB
- https://drive.google.com/file/d/1WHPslTmQmAM9xPJifULS2qAo7hcidB4L/view?usp=sharing WEB
- https://github.com/FlowiseAI/Flowise PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |