GHSA-ggwr-4vr8-g7wv

Apache Airflow Path Traversal vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-22887
Alias
BIT-airflow-2023-22887, PYSEC-2023-104
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an attacker to perform unauthorized file access outside the intended directory structure by manipulating the run_id parameter. This vulnerability is considered low since it requires an authenticated user to exploit it. It is recommended to upgrade to a version that is not affected

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.6.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database