GHSA-gg8r-xjwq-4w92

Cross-site scripting vulnerability in TinyMCE alerts

En bref

Publiée
Mise à jour
CVE
CVE-2022-23494
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

### Impact A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the `image` plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. ### Patches This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. ### Fix To avoid this vulnerability: - Upgrade to TinyMCE 5.10.7 or higher for TinyMCE 5.x. - Upgrade to TinyMCE 6.3.1 or higher for TinyMCE 6.x. ### Workaround To reduce the impact of this vulnerability: - Ensure the the `images_upload_handler` returns a valid value as per the images_upload_handler documentation. ### References - https://www.tiny.cloud/docs/release-notes/release-notes5107/#securityfixes - https://www.tiny.cloud/docs/tinymce/6/6.3-release-notes/#security-fixes ### For more information If you have any questions or comments about this advisory: * Email us at [infosec@tiny.cloud](mailto:infosec@tiny.cloud) * Open an issue in the [TinyMCE repo](https://github.com/tinymce/tinymce/issues)

Paquets affectés

PaquetVersions
npm · tinymceintroduced 6.0.0, fixed 6.3.1
Packagist · tinymce/tinymceintroduced 6.0.0, fixed 6.3.1
NuGet · TinyMCEintroduced 6.0.0, fixed 6.3.1
npm · tinymceintroduced 0, fixed 5.10.7
Packagist · tinymce/tinymceintroduced 0, fixed 5.10.7
NuGet · TinyMCEintroduced 0, fixed 5.10.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database