GHSA-g996-q5r8-w7g2

Symfony Cross-site Scripting (XSS) vulnerability

At a glance

Published
Updated
CVE
CVE-2019-10909
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.

Affected packages

PackageVersions
Packagist · symfony/symfonyintroduced 2.7.0, fixed 2.7.51
Packagist · symfony/symfonyintroduced 2.8.0, fixed 2.8.50
Packagist · symfony/symfonyintroduced 3.0.0, fixed 3.4.26
Packagist · symfony/symfonyintroduced 4.0.0, fixed 4.1.12
Packagist · symfony/symfonyintroduced 4.2.0, fixed 4.2.7
Packagist · symfony/framework-bundleintroduced 2.7.0, fixed 2.7.51
Packagist · symfony/framework-bundleintroduced 2.8.0, fixed 2.8.50
Packagist · symfony/framework-bundleintroduced 3.0.0, fixed 3.4.26
Packagist · symfony/framework-bundleintroduced 4.0.0, fixed 4.1.12
Packagist · symfony/framework-bundleintroduced 4.2.0, fixed 4.2.7
Packagist · drupal/coreintroduced 8.0.0, fixed 8.5.15
Packagist · drupal/coreintroduced 8.6.0, fixed 8.6.15
Packagist · drupal/drupalintroduced 8.0.0, fixed 8.5.15
Packagist · drupal/drupalintroduced 8.6.0, fixed 8.6.15

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database