GHSA-g78h-pf65-46rv

Enhanced Image plugin for CKEditor is vulnerable to Cross-site scripting (XSS)

En bref

Publiée
Mise à jour
CVE
CVE-2018-9861
Alias
DRUPAL-CORE-2018-003
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

The Enhanced Image (aka [image2](https://github.com/ckeditor/ckeditor4/tree/master/plugins/image2)) plugin for CKEditor in versions 4.5.10 through 4.9.1; fixed in 4.9.2, and as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, is vulnerable to cross-site scripting because it allows remote attackers to inject arbitrary web script through a crafted IMG element.

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 8.5.0, fixed 8.5.2
npm · ckeditor-devintroduced 4.5.10, fixed 4.9.2
Packagist · drupal/coreintroduced 8.0, fixed 8.4.7
Packagist · drupal/drupalintroduced 8.0, fixed 8.4.7
Packagist · drupal/drupalintroduced 8.5, fixed 8.5.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database