GHSA-g73c-fw68-pwx3

pgAdmin 4 Vulnerable to Remote Code Execution

En bref

Publiée
Mise à jour
CVE
CVE-2025-2945
Alias
PYSEC-2026-451
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Description

Remote Code Execution security vulnerability in pgAdmin 4 (Query Tool and Cloud Deployment modules). The vulnerability is associated with the 2 POST endpoints; /sqleditor/query_tool/download, where the query_commited parameter and /cloud/deploy endpoint, where the high_availability parameter is unsafely passed to the Python eval() function, allowing arbitrary code execution. This issue affects pgAdmin 4: before 9.2.

Paquets affectés

PaquetVersions
PyPI · pgadmin4introduced 0, fixed 9.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database