GHSA-g643-xq6w-r67c
Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.
At a glance
- Published
- Updated
- CVE
- CVE-2024-45772
- CVSS_V3
- CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L
Description
This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.lucene:lucene-replicator | introduced 4.4.0, fixed 9.12.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-45772 ADVISORY
- https://gitbox.apache.org/repos/asf?p=lucene.git PACKAGE
- https://lists.apache.org/thread/3f3oph7bqnqspb9q5p0gm5mgc1b6thjo WEB
- http://www.openwall.com/lists/oss-security/2024/09/29/1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |