GHSA-g5hg-p3ph-g8qg

Multer vulnerable to Denial of Service via unhandled exception

En bref

Publiée
Mise à jour
CVE
CVE-2025-48997
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

### Impact A vulnerability in Multer versions >=1.4.4-lts.1, <2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. ### Patches Users should upgrade to `2.0.1` ### Workarounds None ### References https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9 https://github.com/expressjs/multer/issues/1233 https://github.com/expressjs/multer/pull/1256

Paquets affectés

PaquetVersions
npm · multerintroduced 1.4.4-lts.1, fixed 2.0.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database