GHSA-fvqr-27wr-82fm

Prototype Pollution in lodash

En bref

Publiée
Mise à jour
CVE
CVE-2018-3721
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Description

Versions of `lodash` before 4.17.5 are vulnerable to prototype pollution. The vulnerable functions are 'defaultsDeep', 'merge', and 'mergeWith' which allow a malicious user to modify the prototype of `Object` via `__proto__` causing the addition or modification of an existing property that will exist on all objects. ## Recommendation Update to version 4.17.5 or later.

Paquets affectés

PaquetVersions
npm · lodashintroduced 0, fixed 4.17.5
RubyGems · lodash-railsintroduced 0, fixed 4.17.5

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database