GHSA-frxj-5j27-f8rf
Externally Controlled Reference to a Resource in Another Sphere, Improper Input Validation, and External Control of File Name or Path in Ansible
At a glance
- Published
- Updated
- CVE
- CVE-2019-14905
- Aliases
- PYSEC-2020-206
- CVSS_V3
- CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N
Description
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.
Affected packages
| Package | Versions |
|---|---|
| PyPI · ansible | introduced 2.7.0a1, fixed 2.7.16 |
| PyPI · ansible | introduced 2.8.0a1, fixed 2.8.8 |
| PyPI · ansible | introduced 2.9.0a1, fixed 2.9.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-14905 ADVISORY
- https://access.redhat.com/errata/RHSA-2020:0216 WEB
- https://access.redhat.com/errata/RHSA-2020:0218 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905 WEB
- https://github.com/advisories/GHSA-frxj-5j27-f8rf ADVISORY
- https://github.com/ansible/ansible PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-206.yaml WEB
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5BNCYPQ4BY5QHBCJOAOPANB5FHATW2BR WEB
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |