GHSA-fq54-2j52-jc42

Next.js Denial of Service (DoS) condition

En bref

Publiée
Mise à jour
CVE
CVE-2024-39693
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

### Impact A Denial of Service (DoS) condition was identified in Next.js. Exploitation of the bug can trigger a crash, affecting the availability of the server. **This vulnerability can affect all Next.js deployments on the affected versions.** ### Patches This vulnerability was resolved in Next.js 13.5 and later. We recommend that users upgrade to a safe version. ### Workarounds There are no official workarounds for this vulnerability. #### Credit * Thai Vu of [flyseccorp.com](http://flyseccorp.com/) * Aonan Guan (@0dd), Senior Cloud Security Engineer

Paquets affectés

PaquetVersions
npm · nextintroduced 13.3.1, fixed 13.5.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database