GHSA-fpww-c55p-cjv6
Payload: Polymorphic join queries could disclose hidden fields
At a glance
- Published
- Updated
- CVE
- CVE-2026-105847
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Description
### Impact A user with query access could use polymorphic join filters to infer hidden or read-restricted field values, including password-reset tokens. You are affected if: - You use an affected Payload version. - Users can query a collection with a polymorphic join to sensitive fields. ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds There is no complete workaround. Restricting read access to sensitive collections reduces exposure but does not replace upgrading.
Affected packages
| Package | Versions |
|---|---|
| npm · payload | introduced 3.0.0, fixed 3.90.0 |
| npm · payload | introduced 4.0.0-canary.0, fixed 4.0.0-canary.34 |
References
- https://github.com/payloadcms/payload/security/advisories/GHSA-fpww-c55p-cjv6 WEB
- https://github.com/payloadcms/payload/commit/caa3f69b5aecc6e7c2b459ed87972cbca9f33ee5 WEB
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.90.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |