GHSA-fpqp-v323-44xv
Cross-site scripting in Apache Ranger
At a glance
- Published
- Updated
- CVE
- CVE-2019-12397
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.ranger:ranger | introduced 0.7.0, fixed 2.0.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12397 ADVISORY
- https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger WEB
- https://lists.apache.org/thread.html/ab2de1adad96f5dbd19d976b28715dfc60dbe75e82a74f48be8ef695@%3Cdev.ranger.apache.org%3E WEB
- https://lists.apache.org/thread.html/cbc6346708ef2b9ffb2555637311bf6294923c609c029389fa39de8f@%3Cdev.ranger.apache.org%3E WEB
- http://www.openwall.com/lists/oss-security/2019/08/08/1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |