GHSA-fjgf-rc76-4x9p
Multer vulnerable to Denial of Service via unhandled exception from malformed request
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-7338
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
### Impact A vulnerability in Multer versions >= 1.4.4-lts.1, < 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed request. This request causes an unhandled exception, leading to a crash of the process. ### Patches Users should upgrade to `2.0.2` ### Workarounds None
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · multer | introduced 1.4.4-lts.1, fixed 2.0.2 |
Références
- https://github.com/expressjs/multer/security/advisories/GHSA-fjgf-rc76-4x9p WEB
- https://nvd.nist.gov/vuln/detail/CVE-2025-7338 ADVISORY
- https://github.com/expressjs/multer/commit/adfeaf669f0e7fe953eab191a762164a452d143b WEB
- https://cna.openjsf.org/security-advisories.html WEB
- https://github.com/expressjs/multer PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |