GHSA-fhj9-cjjh-27vm
Active Record contains deserialization of arbitrary YAML
At a glance
- Published
- Updated
- CVE
- CVE-2013-0277
Description
ActiveRecord in Ruby on Rails before 2.3.17 and 3.x before 3.1.0 allows remote attackers to cause a denial of service or execute arbitrary code via crafted serialized attributes that cause the +serialize+ helper to deserialize arbitrary YAML.
Affected packages
| Package | Versions |
|---|---|
| RubyGems · activerecord | introduced 0, fixed 2.3.17 |
| RubyGems · activerecord | introduced 3.0.0, fixed 3.1.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2013-0277 ADVISORY
- https://github.com/rails/rails/tree/v6.1.4.1/activerecord PACKAGE
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2013-0277.yml WEB
- https://groups.google.com/group/rubyonrails-security/msg/302ec7ce90f13837?dmode=source&output=gplain WEB
- https://puppet.com/security/cve/cve-2013-0277 WEB
- http://lists.apple.com/archives/security-announce/2013/Jun/msg00000.html WEB
- http://lists.opensuse.org/opensuse-updates/2013-03/msg00048.html WEB
- http://securitytracker.com/id?1028109 WEB
- http://support.apple.com/kb/HT5784 WEB
- http://weblog.rubyonrails.org/2013/2/11/SEC-ANN-Rails-3-2-12-3-1-11-and-2-3-17-have-been-released WEB
- http://www.debian.org/security/2013/dsa-2620 WEB
- http://www.openwall.com/lists/oss-security/2013/02/11/6 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |