GHSA-fhg7-m89q-25r3

ReDoS Vulnerability in ua-parser-js version

At a glance

Published
Updated
CVE
CVE-2022-25927
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

### Description: A regular expression denial of service (ReDoS) vulnerability has been discovered in `ua-parser-js`. ### Impact: This vulnerability bypass the library's `MAX_LENGTH` input limit prevention. By crafting a very-very-long user-agent string with specific pattern, an attacker can turn the script to get stuck processing for a very long time which results in a denial of service (DoS) condition. ### Affected Versions: From version `0.7.30` to before versions `0.7.33` / `1.0.33`. ### Patches: A patch has been released to remove the vulnerable regular expression, update to version `0.7.33` / `1.0.33` or later. ### References: [Regular expression Denial of Service - ReDoS](https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS) ### Credits: Thanks to @Snyk who first reported the issue.

Affected packages

PackageVersions
npm · ua-parser-jsintroduced 0.7.30, fixed 0.7.33
npm · ua-parser-jsintroduced 0.8.0, fixed 1.0.33

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database