GHSA-ffvq-7w96-97p7

Denial of Service in Spring Framework

At a glance

Published
Updated
CVE
CVE-2018-15756
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Spring Framework, version 5.1, versions 5.0.x prior to 5.0.10, versions 4.3.x prior to 4.3.20, and older unsupported versions on the 4.2.x branch provide support for range requests when serving static resources through the ResourceHttpRequestHandler, or starting in 5.0 when an annotated controller returns an org.springframework.core.io.Resource. A malicious user (or attacker) can add a range header with a high number of ranges, or with wide ranges that overlap, or both, for a denial of service attack. This vulnerability affects applications that depend on either spring-webmvc or spring-webflux. Such applications must also have a registration for serving static resources (e.g. JS, CSS, images, and others), or have an annotated controller that returns an org.springframework.core.io.Resource. Spring Boot applications that depend on spring-boot-starter-web or spring-boot-starter-webflux are ready to serve static resources out of the box and are therefore vulnerable.

Affected packages

PackageVersions
Maven · org.springframework:spring-coreintroduced 5.1.0.RELEASE, fixed 5.1.1.RELEASE
Maven · org.springframework:spring-coreintroduced 5.0.0.RELEASE, fixed 5.0.10.RELEASE
Maven · org.springframework:spring-coreintroduced 4.2.0.RELEASE, fixed 4.3.20.RELEASE

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database