GHSA-ffgg-vphh-v273

Incomplete List of Disallowed Inputs in Jenkins

At a glance

Published
Updated
CVE
CVE-2017-2602
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Description

Jenkins before versions 2.44 and 2.32.2 is vulnerable to an improper blacklisting of the Pipeline metadata files in the agent-to-master security subsystem. This could allow metadata files to be written to by malicious agents (SECURITY-358).

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.32.2
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.34, fixed 2.44

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database